ham/predict - The NetBSD Packages Collection

Curses satellite tracking/orbital prediction program

PREDICT provides real-time satellite tracking and orbital prediction
information to users and client applications in a variety of ways:

    Through the system console
    Through the command line
    Through a network socket
    Through the generation of audio speech

Data such as a spacecraft's sub-satellite point, azimuth and elevation
headings, Doppler shift, path loss, slant range, orbital altitude,
orbital velocity, footprint diameter, orbital phase (mean anomaly),
squint angle, eclipse depth, the time and date of the next AOS (or LOS
of the current pass), orbit number, and sunlight and visibility
information are provided on a real-time basis. PREDICT can also track
(or predict the position of) the Sun and Moon. PREDICT also has the
ability to control AZ/EL antenna rotators to maintain accurate
orientation in the direction of communication satellites. As an aid in
locating and tracking satellites through optical means, PREDICT can
articulate tracking coordinates and visibility information as plain
speech.

Build dependencies

pkgtools/cwrappers

Runtime dependencies

audio/sox

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfpredict-2.2.6.tgz
NetBSD 8.0earmv7hfpredict-2.2.6.tgz
NetBSD 8.0earmv7hfpredict-2.2.6.tgz
NetBSD 8.0i386predict-2.2.6.tgz
NetBSD 8.0i386predict-2.2.6.tgz
NetBSD 8.0i386predict-2.2.6.tgz
NetBSD 8.0powerpcpredict-2.2.6.tgz
NetBSD 8.0powerpcpredict-2.2.6.tgz
NetBSD 8.0powerpcpredict-2.2.6.tgz
NetBSD 8.0powerpcpredict-2.2.6.tgz
NetBSD 8.0x86_64predict-2.2.6.tgz
NetBSD 8.0x86_64predict-2.2.6.tgz
NetBSD 8.0x86_64predict-2.2.6.tgz
NetBSD 9.0aarch64predict-2.2.6.tgz
NetBSD 9.0aarch64predict-2.2.6.tgz
NetBSD 9.0aarch64predict-2.2.6.tgz
NetBSD 9.0alphapredict-2.2.6.tgz
NetBSD 9.0alphapredict-2.2.6.tgz
NetBSD 9.0alphapredict-2.2.6.tgz
NetBSD 9.0earmv6hfpredict-2.2.6.tgz
NetBSD 9.0earmv6hfpredict-2.2.6.tgz
NetBSD 9.0earmv6hfpredict-2.2.6.tgz
NetBSD 9.0earmv6hfpredict-2.2.6.tgz
NetBSD 9.0earmv7hfpredict-2.2.6.tgz
NetBSD 9.0earmv7hfpredict-2.2.6.tgz
NetBSD 9.0earmv7hfpredict-2.2.6.tgz
NetBSD 9.0earmv7hfpredict-2.2.6.tgz
NetBSD 9.0earmv7hfpredict-2.2.6.tgz
NetBSD 9.0i386predict-2.2.6.tgz
NetBSD 9.0i386predict-2.2.6.tgz
NetBSD 9.0i386predict-2.2.6.tgz
NetBSD 9.0powerpcpredict-2.2.6.tgz
NetBSD 9.0powerpcpredict-2.2.6.tgz
NetBSD 9.0powerpcpredict-2.2.6.tgz
NetBSD 9.0sparc64predict-2.2.6.tgz
NetBSD 9.0sparc64predict-2.2.6.tgz
NetBSD 9.0sparc64predict-2.2.6.tgz
NetBSD 9.0sparcpredict-2.2.6.tgz
NetBSD 9.0x86_64predict-2.2.6.tgz
NetBSD 9.0x86_64predict-2.2.6.tgz
NetBSD 9.0x86_64predict-2.2.6.tgz
NetBSD 9.0x86_64predict-2.2.6.tgz
NetBSD 9.0x86_64predict-2.2.6.tgz
NetBSD 9.0x86_64predict-2.2.6.tgz
NetBSD 9.0x86_64predict-2.2.6.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.