devel/gmake - The NetBSD Packages Collection

GNU version of 'make' utility

Make is a tool which controls the generation of executables and
other non-source files of a program from the program's source files.

Make gets its knowledge of how to build your program from a file
called the makefile, which lists each of the non-source files and
how to compute it from other files. When you write a program, you
should write a makefile for it, so that it is possible to use Make
to build and install the program.

This is the GNU version of make.

Build dependencies

pkgtools/cwrappers

Runtime dependencies

(none)

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfgmake-4.2.1nb1.tgz
NetBSD 8.0earmv7hfgmake-4.2.1nb1.tgz
NetBSD 8.0earmv7hfgmake-4.2.1nb1.tgz
NetBSD 8.0earmv7hfgmake-4.3nb2.tgz
NetBSD 8.0earmv7hfgmake-4.2.1nb1.tgz
NetBSD 8.0i386gmake-4.2.1nb1.tgz
NetBSD 8.0i386gmake-4.2.1nb1.tgz
NetBSD 8.0i386gmake-4.2.1nb1.tgz
NetBSD 8.0i386gmake-4.3nb2.tgz
NetBSD 8.0powerpcgmake-4.2.1nb1.tgz
NetBSD 8.0powerpcgmake-4.2.1nb1.tgz
NetBSD 8.0powerpcgmake-4.2.1nb1.tgz
NetBSD 8.0powerpcgmake-4.2.1nb1.tgz
NetBSD 8.0x86_64gmake-4.2.1nb1.tgz
NetBSD 8.0x86_64gmake-4.2.1nb1.tgz
NetBSD 8.0x86_64gmake-4.2.1nb1.tgz
NetBSD 8.0x86_64gmake-4.3nb2.tgz
NetBSD 9.0aarch64gmake-4.3nb2.tgz
NetBSD 9.0aarch64gmake-4.2.1nb1.tgz
NetBSD 9.0aarch64gmake-4.2.1nb1.tgz
NetBSD 9.0aarch64gmake-4.2.1nb1.tgz
NetBSD 9.0alphagmake-4.2.1nb1.tgz
NetBSD 9.0alphagmake-4.3nb2.tgz
NetBSD 9.0earmgmake-4.2.1nb1.tgz
NetBSD 9.0earmgmake-4.3nb2.tgz
NetBSD 9.0earmv6hfgmake-4.2.1nb1.tgz
NetBSD 9.0earmv6hfgmake-4.2.1nb1.tgz
NetBSD 9.0earmv6hfgmake-4.2.1nb1.tgz
NetBSD 9.0earmv6hfgmake-4.2.1nb1.tgz
NetBSD 9.0earmv6hfgmake-4.3nb2.tgz
NetBSD 9.0earmv7hfgmake-4.2.1nb1.tgz
NetBSD 9.0earmv7hfgmake-4.2.1nb1.tgz
NetBSD 9.0earmv7hfgmake-4.2.1nb1.tgz
NetBSD 9.0earmv7hfgmake-4.2.1nb1.tgz
NetBSD 9.0earmv7hfgmake-4.2.1nb1.tgz
NetBSD 9.0earmv7hfgmake-4.3nb2.tgz
NetBSD 9.0earmv7hfgmake-4.3nb2.tgz
NetBSD 9.0earmv7hfgmake-4.2.1nb1.tgz
NetBSD 9.0i386gmake-4.2.1nb1.tgz
NetBSD 9.0i386gmake-4.2.1nb1.tgz
NetBSD 9.0i386gmake-4.2.1nb1.tgz
NetBSD 9.0i386gmake-4.3nb2.tgz
NetBSD 9.0m68kgmake-4.2.1nb1.tgz
NetBSD 9.0m68kgmake-4.2.1nb1.tgz
NetBSD 9.0m68kgmake-4.3nb2.tgz
NetBSD 9.0mips64ebgmake-4.2.1nb1.tgz
NetBSD 9.0mips64ebgmake-4.2.1nb1.tgz
NetBSD 9.0mips64ebgmake-4.2.1nb1.tgz
NetBSD 9.0mips64ebgmake-4.3nb2.tgz
NetBSD 9.0mipselgmake-4.2.1nb1.tgz
NetBSD 9.0mipselgmake-4.2.1nb1.tgz
NetBSD 9.0mipselgmake-4.3nb2.tgz
NetBSD 9.0powerpcgmake-4.2.1nb1.tgz
NetBSD 9.0powerpcgmake-4.2.1nb1.tgz
NetBSD 9.0powerpcgmake-4.2.1nb1.tgz
NetBSD 9.0powerpcgmake-4.2.1nb1.tgz
NetBSD 9.0powerpcgmake-4.2.1nb1.tgz
NetBSD 9.0sh3elgmake-4.2.1nb1.tgz
NetBSD 9.0sh3elgmake-4.2.1nb1.tgz
NetBSD 9.0sh3elgmake-4.2.1nb1.tgz
NetBSD 9.0sh3elgmake-4.3nb2.tgz
NetBSD 9.0sparc64gmake-4.2.1nb1.tgz
NetBSD 9.0sparc64gmake-4.3nb2.tgz
NetBSD 9.0sparcgmake-4.2.1nb1.tgz
NetBSD 9.0sparcgmake-4.2.1nb1.tgz
NetBSD 9.0sparcgmake-4.2.1nb1.tgz
NetBSD 9.0sparcgmake-4.3nb2.tgz
NetBSD 9.0vaxgmake-4.2.1nb1.tgz
NetBSD 9.0vaxgmake-4.2.1nb1.tgz
NetBSD 9.0vaxgmake-4.2.1nb1.tgz
NetBSD 9.0vaxgmake-4.3nb2.tgz
NetBSD 9.0x86_64gmake-4.2.1nb1.tgz
NetBSD 9.0x86_64gmake-4.3nb2.tgz
NetBSD 9.0x86_64gmake-4.2.1nb1.tgz
NetBSD 9.0x86_64gmake-4.2.1nb1.tgz
NetBSD 9.0x86_64gmake-4.2.1nb1.tgz
NetBSD 9.0x86_64gmake-4.2.1nb1.tgz
NetBSD 9.0x86_64gmake-4.3nb2.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

nls
Use native language support.

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.