chat/unrealircd - The NetBSD Packages Collection

Advanced IRC server with IPv6 and SSL support

UnrealIRCd is an IRC server based on the branch of IRCu called
Dreamforge, formerly used by the DALnet IRC Network.

Key features include SSL, cloaking, its advanced anti-flood and
anti-spam systems, swear filtering and module support.

Build dependencies

pkgtools/cwrappers devel/gmake devel/pkgconf

Runtime dependencies

net/libcares devel/pcre2 security/argon2 net/libcares devel/pcre2

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfunrealircd-5.0.7.tgz
NetBSD 8.0earmv7hfunrealircd-5.0.4nb1.tgz
NetBSD 8.0earmv7hfunrealircd-5.0.8.tgz
NetBSD 8.0i386unrealircd-5.0.4nb1.tgz
NetBSD 8.0i386unrealircd-5.0.7.tgz
NetBSD 8.0i386unrealircd-5.0.8.tgz
NetBSD 8.0powerpcunrealircd-5.0.4nb1.tgz
NetBSD 8.0powerpcunrealircd-5.0.8.tgz
NetBSD 8.0powerpcunrealircd-5.0.7.tgz
NetBSD 8.0powerpcunrealircd-5.0.8.tgz
NetBSD 8.0x86_64unrealircd-5.0.8.tgz
NetBSD 8.0x86_64unrealircd-5.0.4nb1.tgz
NetBSD 8.0x86_64unrealircd-5.0.7.tgz
NetBSD 9.0aarch64unrealircd-5.0.8.tgz
NetBSD 9.0aarch64unrealircd-5.0.4nb1.tgz
NetBSD 9.0aarch64unrealircd-5.0.7.tgz
NetBSD 9.0alphaunrealircd-5.0.8.tgz
NetBSD 9.0alphaunrealircd-5.0.4nb1.tgz
NetBSD 9.0alphaunrealircd-5.0.7.tgz
NetBSD 9.0earmunrealircd-5.0.4nb1.tgz
NetBSD 9.0earmv6hfunrealircd-5.0.8.tgz
NetBSD 9.0earmv6hfunrealircd-5.0.4nb1.tgz
NetBSD 9.0earmv6hfunrealircd-5.0.7.tgz
NetBSD 9.0earmv6hfunrealircd-5.0.7.tgz
NetBSD 9.0earmv7hfunrealircd-5.0.8.tgz
NetBSD 9.0earmv7hfunrealircd-5.0.4nb1.tgz
NetBSD 9.0earmv7hfunrealircd-5.0.7.tgz
NetBSD 9.0earmv7hfunrealircd-5.0.7.tgz
NetBSD 9.0earmv7hfunrealircd-5.0.8.tgz
NetBSD 9.0i386unrealircd-5.0.4nb1.tgz
NetBSD 9.0i386unrealircd-5.0.7.tgz
NetBSD 9.0i386unrealircd-5.0.8.tgz
NetBSD 9.0mips64ebunrealircd-5.0.8.tgz
NetBSD 9.0mips64ebunrealircd-5.0.4nb1.tgz
NetBSD 9.0mips64ebunrealircd-5.0.7.tgz
NetBSD 9.0powerpcunrealircd-5.0.7.tgz
NetBSD 9.0powerpcunrealircd-5.0.4nb1.tgz
NetBSD 9.0powerpcunrealircd-5.0.8.tgz
NetBSD 9.0powerpcunrealircd-5.0.8.tgz
NetBSD 9.0sparc64unrealircd-5.0.8.tgz
NetBSD 9.0sparc64unrealircd-5.0.4nb1.tgz
NetBSD 9.0sparc64unrealircd-5.0.7.tgz
NetBSD 9.0sparcunrealircd-5.0.8.tgz
NetBSD 9.0sparcunrealircd-5.0.7.tgz
NetBSD 9.0x86_64unrealircd-5.0.4nb1.tgz
NetBSD 9.0x86_64unrealircd-5.0.7.tgz
NetBSD 9.0x86_64unrealircd-5.0.8.tgz
NetBSD 9.0x86_64unrealircd-5.0.8.tgz
NetBSD 9.0x86_64unrealircd-5.0.4nb1.tgz
NetBSD 9.0x86_64unrealircd-5.0.7.tgz
NetBSD 9.0x86_64unrealircd-5.0.8.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

unrealircd-no-operoverride
Disable operator override.
unrealircd-operoverride-verify
Require opers to /invite themselves into a +s or +p channel.
unrealircd-remoteinc
Enable remote includes.
unrealircd-showlistmodes
Show the modes a channel has set in the /list output.

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.