chat/psi - The NetBSD Packages Collection

Psi XMPP/Jabber Client

XMPP is an open, XML based, distributed, Instant Messaging system
that seeks to be the standard IM network.

Psi is a client for the Jabber system. Written in C++ and based on
the Qt library, there are versions available for NetBSD, Linux (and
other flavors of Unix/X11), Microsoft Windows, and Apple MacOS X.
Psi is released under the GNU General Public License.

Features:
* Message (ICQ-style) and Chat (AIM-style) modes
* Drag and drop to send to multiple contacts
* Full Unicode support
* Secure connections
* Saving contact list locally, and server sync on login
* Icon Themes
* Agent registration and searching
* Retrieving and updating User Info
* Sound support for incoming events
* Auto-away after a configurable amount of time
* Tray/dock icon for KDE/GNOME environments
* Language plugins
* OpenPGP integration (via GnuPG via security/qca2-gnupg)
* Groupchat invites / private-messaging
* File transfer

Build dependencies

pkgtools/x11-links x11/xorgproto x11/xcb-proto pkgtools/cwrappers devel/glib2-tools devel/libtool-base devel/gmake devel/pkgconf

Runtime dependencies

security/qca2-qt5-ossl textproc/aspell textproc/hunspell devel/libidn security/qca2-qt5 x11/qt5-qtbase x11/qt5-qtmultimedia x11/qt5-qtx11extras textproc/aspell textproc/hunspell devel/libidn security/qca2-qt5 x11/qt5-qtbase x11/qt5-qtmultimedia x11/qt5-qtx11extras

Binary packages

OSArchitectureVersion
NetBSD 8.0i386psi-1.4nb10.tgz
NetBSD 8.0powerpcpsi-1.4nb10.tgz
NetBSD 8.0powerpcpsi-1.5nb2.tgz
NetBSD 8.0powerpcpsi-1.5nb2.tgz
NetBSD 8.0x86_64psi-1.5nb2.tgz
NetBSD 8.0x86_64psi-1.4nb10.tgz
NetBSD 8.0x86_64psi-1.5.tgz
NetBSD 9.0aarch64psi-1.5nb2.tgz
NetBSD 9.0aarch64psi-1.4nb10.tgz
NetBSD 9.0aarch64psi-1.5.tgz
NetBSD 9.0earmv7hfpsi-1.4nb10.tgz
NetBSD 9.0i386psi-1.4nb10.tgz
NetBSD 9.0i386psi-1.5.tgz
NetBSD 9.0i386psi-1.5nb2.tgz
NetBSD 9.0powerpcpsi-1.5.tgz
NetBSD 9.0sparc64psi-1.5nb2.tgz
NetBSD 9.0sparc64psi-1.4nb10.tgz
NetBSD 9.0x86_64psi-1.5.tgz
NetBSD 9.0x86_64psi-1.5nb1.tgz
NetBSD 9.0x86_64psi-1.5nb1.tgz
NetBSD 9.0x86_64psi-1.5nb2.tgz
NetBSD 9.0x86_64psi-1.4nb10.tgz
NetBSD 9.0x86_64psi-1.5.tgz
NetBSD 9.0x86_64psi-1.5nb2.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

aspell
Add spell checking support using aspell.
hunspell
Add spell checking support using hunspell.
lang-be
Add Belarusian language support.
lang-cs
Add Czech language support.
lang-de
Add German language support.
lang-eo
Add Esperanto language support.
lang-es
Add Spanish language support.
lang-es-es
lang-fr
Add French language support.
lang-it
Add Italian language support.
lang-ja
Add Japanese language support.
lang-mk
lang-pl
Add Polish language support.
lang-pt-br
Add Brazilian Portuguese language support.
lang-ru
Add Russian language support.
lang-sl
Add Slovenian language support.
lang-sv
Add Swedish language support.
lang-uk
Add Ukrainian language support.
lang-ur-pk
lang-vi
lang-zh-cn
Add Chinese Simplified language support.
lang-zh-tw
Add Chinese Traditional language support.
whiteboard
xscreensaver

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.