chat/icbirc - The NetBSD Packages Collection

Proxy IRC client and ICB server

icbirc is a proxy that allows users to connect an IRC client to an ICB server.
The proxy accepts client connections, connects to the server, and for-
wards data between those two connections.

Commands from the IRC client are translated to ICB commands and forwarded
to the ICB server. Messages from the ICB server are translated to IRC
messages and forwarded to the IRC client.

Build dependencies

pkgtools/cwrappers

Runtime dependencies

(none)

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hficbirc-1.9.tgz
NetBSD 8.0earmv7hficbirc-1.9.tgz
NetBSD 8.0earmv7hficbirc-1.9.tgz
NetBSD 8.0i386icbirc-1.9.tgz
NetBSD 8.0i386icbirc-1.9.tgz
NetBSD 8.0i386icbirc-1.9.tgz
NetBSD 8.0powerpcicbirc-1.9.tgz
NetBSD 8.0powerpcicbirc-1.9.tgz
NetBSD 8.0powerpcicbirc-1.9.tgz
NetBSD 8.0powerpcicbirc-1.9.tgz
NetBSD 8.0x86_64icbirc-1.9.tgz
NetBSD 8.0x86_64icbirc-1.9.tgz
NetBSD 8.0x86_64icbirc-1.9.tgz
NetBSD 9.0aarch64icbirc-1.9.tgz
NetBSD 9.0aarch64icbirc-1.9.tgz
NetBSD 9.0aarch64icbirc-1.9.tgz
NetBSD 9.0alphaicbirc-1.9.tgz
NetBSD 9.0alphaicbirc-1.9.tgz
NetBSD 9.0alphaicbirc-1.9.tgz
NetBSD 9.0earmicbirc-1.9.tgz
NetBSD 9.0earmicbirc-1.9.tgz
NetBSD 9.0earmv6hficbirc-1.9.tgz
NetBSD 9.0earmv6hficbirc-1.9.tgz
NetBSD 9.0earmv6hficbirc-1.9.tgz
NetBSD 9.0earmv6hficbirc-1.9.tgz
NetBSD 9.0earmv7hficbirc-1.9.tgz
NetBSD 9.0earmv7hficbirc-1.9.tgz
NetBSD 9.0earmv7hficbirc-1.9.tgz
NetBSD 9.0earmv7hficbirc-1.9.tgz
NetBSD 9.0earmv7hficbirc-1.9.tgz
NetBSD 9.0i386icbirc-1.9.tgz
NetBSD 9.0i386icbirc-1.9.tgz
NetBSD 9.0i386icbirc-1.9.tgz
NetBSD 9.0mips64ebicbirc-1.9.tgz
NetBSD 9.0mips64ebicbirc-1.9.tgz
NetBSD 9.0mips64ebicbirc-1.9.tgz
NetBSD 9.0powerpcicbirc-1.9.tgz
NetBSD 9.0powerpcicbirc-1.9.tgz
NetBSD 9.0powerpcicbirc-1.9.tgz
NetBSD 9.0sparc64icbirc-1.9.tgz
NetBSD 9.0sparc64icbirc-1.9.tgz
NetBSD 9.0sparc64icbirc-1.9.tgz
NetBSD 9.0sparc64icbirc-1.9.tgz
NetBSD 9.0sparcicbirc-1.9.tgz
NetBSD 9.0sparcicbirc-1.9.tgz
NetBSD 9.0sparcicbirc-1.9.tgz
NetBSD 9.0x86_64icbirc-1.9.tgz
NetBSD 9.0x86_64icbirc-1.9.tgz
NetBSD 9.0x86_64icbirc-1.9.tgz
NetBSD 9.0x86_64icbirc-1.9.tgz
NetBSD 9.0x86_64icbirc-1.9.tgz
NetBSD 9.0x86_64icbirc-1.9.tgz
NetBSD 9.0x86_64icbirc-1.9.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.