chat/gloox - The NetBSD Packages Collection

Jabber/XMPP client library

gloox is a rock-solid, full-featured Jabber/XMPP client library,
written in C++. It makes writing spec-compliant clients easy and
allows for hassle-free integration of Jabber/XMPP functionality
into existing applications.

Build dependencies

pkgtools/cwrappers devel/libtool-base devel/automake devel/autoconf devel/pkgconf

Runtime dependencies

security/gnutls security/libgcrypt devel/libidn security/gnutls security/libgcrypt devel/libidn

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfgloox-1.0.17nb6.tgz
NetBSD 8.0earmv7hfgloox-1.0.17nb6.tgz
NetBSD 8.0earmv7hfgloox-1.0.17nb6.tgz
NetBSD 8.0i386gloox-1.0.17nb6.tgz
NetBSD 8.0i386gloox-1.0.17nb6.tgz
NetBSD 8.0i386gloox-1.0.17nb6.tgz
NetBSD 8.0powerpcgloox-1.0.17nb6.tgz
NetBSD 8.0powerpcgloox-1.0.17nb6.tgz
NetBSD 8.0powerpcgloox-1.0.17nb6.tgz
NetBSD 8.0powerpcgloox-1.0.17nb6.tgz
NetBSD 8.0x86_64gloox-1.0.17nb6.tgz
NetBSD 8.0x86_64gloox-1.0.17nb6.tgz
NetBSD 8.0x86_64gloox-1.0.17nb6.tgz
NetBSD 9.0aarch64gloox-1.0.17nb6.tgz
NetBSD 9.0aarch64gloox-1.0.17nb6.tgz
NetBSD 9.0aarch64gloox-1.0.17nb6.tgz
NetBSD 9.0alphagloox-1.0.17nb6.tgz
NetBSD 9.0alphagloox-1.0.17nb6.tgz
NetBSD 9.0alphagloox-1.0.17nb6.tgz
NetBSD 9.0earmgloox-1.0.17nb6.tgz
NetBSD 9.0earmgloox-1.0.17nb6.tgz
NetBSD 9.0earmv6hfgloox-1.0.17nb6.tgz
NetBSD 9.0earmv6hfgloox-1.0.17nb6.tgz
NetBSD 9.0earmv6hfgloox-1.0.17nb6.tgz
NetBSD 9.0earmv6hfgloox-1.0.17nb6.tgz
NetBSD 9.0earmv7hfgloox-1.0.17nb6.tgz
NetBSD 9.0earmv7hfgloox-1.0.17nb6.tgz
NetBSD 9.0earmv7hfgloox-1.0.17nb6.tgz
NetBSD 9.0earmv7hfgloox-1.0.17nb6.tgz
NetBSD 9.0earmv7hfgloox-1.0.17nb6.tgz
NetBSD 9.0i386gloox-1.0.17nb6.tgz
NetBSD 9.0i386gloox-1.0.17nb6.tgz
NetBSD 9.0i386gloox-1.0.17nb6.tgz
NetBSD 9.0mips64ebgloox-1.0.17nb6.tgz
NetBSD 9.0mips64ebgloox-1.0.17nb6.tgz
NetBSD 9.0mips64ebgloox-1.0.17nb6.tgz
NetBSD 9.0powerpcgloox-1.0.17nb6.tgz
NetBSD 9.0powerpcgloox-1.0.17nb6.tgz
NetBSD 9.0powerpcgloox-1.0.17nb6.tgz
NetBSD 9.0sh3elgloox-1.0.17nb6.tgz
NetBSD 9.0sparc64gloox-1.0.17nb6.tgz
NetBSD 9.0sparc64gloox-1.0.17nb6.tgz
NetBSD 9.0sparc64gloox-1.0.17nb6.tgz
NetBSD 9.0sparc64gloox-1.0.17nb6.tgz
NetBSD 9.0sparcgloox-1.0.17nb6.tgz
NetBSD 9.0sparcgloox-1.0.17nb6.tgz
NetBSD 9.0sparcgloox-1.0.17nb6.tgz
NetBSD 9.0x86_64gloox-1.0.17nb6.tgz
NetBSD 9.0x86_64gloox-1.0.17nb6.tgz
NetBSD 9.0x86_64gloox-1.0.17nb6.tgz
NetBSD 9.0x86_64gloox-1.0.17nb6.tgz
NetBSD 9.0x86_64gloox-1.0.17nb6.tgz
NetBSD 9.0x86_64gloox-1.0.17nb6.tgz
NetBSD 9.0x86_64gloox-1.0.17nb6.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

debug
Enable debugging facilities in the package.
gnutls
Enable GNU TLS support.
openssl
Enable OpenSSL support.

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.